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1. Introduction 
 

Thank you for purchasing the Allo.com’s MegaPBX, a SIP-based, affordable, feature-rich 
converging communication platform designed to meet the communication requirements for 
small to medium sized enterprises. 

The MegaPBX provides the cutting-edge IP-based communications that businesses demand 
while leveraging existing infrastructure and providing a smooth transition into IP telephony. 
Based on open standard SIP, the MegaPBX  can easily integrate into and interoperate with 
other components of your existing communications network while providing a rich set of features 
to reduce costs and increase productivity.  

The MegaPBX also includes an Setup wizard and an intuitive user interface that allows users to 
quickly configure extensions, Voicemail, fax mail, Voicemail& fax to email, conference bridges 
and other enhanced features can be turned on with minimal effort via the web configuration 
interface.  

Equipment Packaging 

1) One MegaPBX unit 

2) One 12 Volt power adapter 

3) One Ethernet cable 
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1.1 Typical setup of MegaPBX 
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2. Getting Started With the MegaPBX 

2.1 Hardware Setup 

 

1. Plug one end of the RJ45 Ethernet cable into your Network Switch 

2.        Plug the other end of the RJ45 Ethernet cable into the WAN port of the    
MegaPBX 

3.        Connect a PC to the LAN port of the MegaPBX, Enable the DHCP option in the      
Network   Settings of the PC 

3. Plug the Power Adapter included into an available power outlet 

4. Plug the other end of the Power Adapter into the “DC-IN” port of the MegaPBX 

5. The MegaPBX will power up (Boot up time takes about 160 secs) 

Important Note:  
Use straight – through Ethernet cable to connect between the MegaPBX to Router/Switch/PC 
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Notification LEDs (On the Front Panel): 

 

2.2 Access the web GUI: 
MegaPBX Web GUI can be accessed either through WAN or LAN interface. Steps to 

Access the GUI during the initial setup through LAN interface: 

Step 1: Make the  setup as mentioned  previously in the hardware setup 

Step 3: Make sure the Network setting of the PC is set in automatic mode (i.e. DHCP mode). An 
IP address will be accessed to the PC in the 192.168.113.xxx series (By default DHCP server 
releases IP address on the LAN interface). 

Step 4: Launch the web browser and enter the URL http://192.168.113.2 to open the login page 
of MegaPBX Graphical Interface. 

 

Step 5: Login using the default username & password (Default: Username: admin; Password: 
admin). Successful login takes you to the Dashboard page (figure 2-1). Observe the WAN IP 
address on the dashboard, this will be used to access the GUI from the WAN interface. 

After successful login we get a MegaPBX Home Dash Board. To guarantee the system safety,  
When login for the first time, we need to modify Password. For modifying the password go to  
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TOOLS->Admin Account Option  
 
Important Note:  
Recommended web browser to access GUI are Mozilla Firefox 

3. Setting Up Features 
 

3.1 System Dash Board 

 

MegaPBX Dash Board Shows the Status information such as SIP Station status, SIP trunk 
Status, Call Statistics, System Status and So on. 

MegaPBX can be easily configured for various settings through the “Quick configuration tool” 
available on the Dashboard. 
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3.2 Quick Configuration Tool: 
Click on the “Quick Configuration Tool” in the MegaPBX Dash Board which leads to the 
General Settings Page. 

3.2.1General Settings: 
Select the Time Zone as per your country’s time zone. 

Here you can configure the Date and Time, either manually or through NTP (Ex: pool.ntp.org) 
and Click on “Apply” button for saving the configuration. 

 

 

3.2.2 Email Options: 
To configure the MegaPBX to send out voicemail/FAX via email, the related SMTP setting must 
be configured. 
 
Mail Server:   Enter the domain name of the Email Server address of the particular authorized 
email client account. 
Email ID: Enter the email ID of the   particular authorized email client account. 
Click on “SAVE” button for saving the configuration. 
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3.2.3 Administrator Password Setting: 
 
To guarantee the system safety, modify the Admin Password.  Its recommended to set 
alphanumeric password with special characters. 
Click on “SAVE” button for saving the configuration. 

 
 

3.2.4 SIP Extension Group Configuration: 
By Default there is a Extension group called “Default sip”. You can limit or enable PBX features 
for extensions by creating Extensions group. 
 
You can enable/disable Features like Voice mail, FAX, Call Pickup, callback, callpark and so on. 
You can also configure various Codec’s and can also prioritize the active Codecs using the up 
and down arrows. 
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Click on “SAVE “button. 
You can create new SIP Group Configuration by clicking “CREATE”  

3.2.5 SIP Extensions Configuration: 
You can create here the range of IP Extensions (Eg: 6000 to 6020)  

 
 

Important Note: You can add Extension range of Max 50 users at a time and the maximum of 
250 SIP extensions  



MegaPBX- Setting up features 

14 
User manual V2.0                                                                                                   www.allo.com 

3.2.6 SIP Trunk Groups: 

 
 

Group Name: Enter a descriptive name in this field to identify the configured SIP trunk Group. 
By default: DefSIPtrunk 

DTMF Mode: You can enable/Disable the Email alerts on arrival of new voicemail & MWI 
Features:  You can enable/Disable NAT, FAX and DID Routing 
      NAT: It should be check if the device is behind a NAT router. Enable this option to              
avoid NAT Traversal issues. 
      Fax: If it is checked then T.38 supported, if unchecked only FAX pass through is   
supported. 
      DID Routing: This field is used to route incoming calls when a DID (Direct Inward 
Dialing #)   is used instead of the account ID. It is very helpful when there are several DIDs             
related to the same (static) trunk provided by your SIP Trunk Service Provider. 
Codec Configuration: This field allows you to enable a Codec's according to your preference. 
 
Click on “SAVE “button. 
You can create new SIP Group Configuration by clicking “CREATE”  
 

3.2.7 SIP Trunks: 
This is where you can configure VoIP Service provider Accounts 
 
The details of the Configuration page are as follows: 
Account Name: SIP service subscriber name which will be used for Caller ID display. 
User Name: User account information, provided by VoIP service provider (ITSP), usually has 
the form of digit similar to phone number or actually a phone number. 
Proxy Address: IP address or Domain name provided by VoIP service provider. By default port 
number will be 5060 
Out Bound Proxy Address: A proxy that receives requests from a client, even though it may 
not be the Server resolved by the Request-URI. Out bound proxy IP Address provided by the 
VoIP service provider. 
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Authentication: Used for SIP trunk authentication.  If Authentication is required, check 
Authentication box and enter Authentication user name and Password provided by the VoIP 
service provider. 
Registration Mode: Enable if registration required from the VoIP Service provider 
Registrar Address: Domain name/ IP Address of registrar. If the registrar address is not 
provided by the Service provider use the proxy address itself 
Bridge PIN: This password is required to bridge the VoIP calls between two trunks. If not 
required, leave it blank. 
SIP Trunk Group: Select the appropriate SIP Trunk Group. 
Inbound Call Handling: This feature allows you to route the incoming calls to particular 
extension/ IVR/Queue/Voicemail Group. 
 

 

 

3.2.13 Dial out Rules: 
Patterns: We should take care to create valid dial plans so as to ensure that our calls are 
handled via the appropriate trunks. Many people get confused about dial plan pattern 
construction; but it doesn't have to be that difficult. The following table lists the special dial plan 
pattern characters and their significance: 

 
  Special Dial plan Pattern Characters                             Significance 
   
     X               Matches any digit from 0-9 
               Z                                                                                    Matches any digit from 1-9 
               N                                                                                   Matches any digit from 2-9 

   [1237-9]                                                                          matches any digit or letter in the brackets (in this            
                     Example 1,2,3,7,8,9 

           .                                                                    Wildcard; matches one or more characters 

           |                                                                   Separates dialing prefix from number 

For e.g. adding '01|X.' in the Dial Pattern and selected a “VoIP Provider1” in Trunk Sequence, 

will allow user to dial 014567807890 numbers, so that 01 will be stripped off from the dialed 
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digits and only 4567807890 are dialed through VoIP Provider1. (Where as a VoIP Provider1 is 

an account which is registered to any Internet Telephony Service Provider) 

Second way is, choose provider or trunk based on actual number dialed. This type of rule will 

allow the user to choose suitable provider based on actual number. For e.g. adding ' 44X.' in 

Dial Pattern and selected VoIP Provider 2 in trunk sequence, PBX will allow number dialed from 

44 + (any digit from 0 to 9) like 449872837532 will route through VoIP Provider 2. If the ITSP / 

VoIP provider offer cheaper rates for the region where number starts from 44 users can make 

use of this rule. 

Enable Ceasing Of Trunk: This feature enables 2-stage dialing. For Example: If you have 
created dial out rule with pattern “0” and enable ceasing of trunk. While dialing out you need to 
press “0” and wait for the line dial tone and enter Calles number 

Trunk Sequence: The final phase of creating the dial plan is setting the trunk sequence. Not all 

dial plans have multiple trunks available for use, such as the remote extensions example. In 

other cases, such as long-distance dialing, our preferred carrier would be first, followed by a 

backup provider in case we max out the available channels, or if the system was unable to 

contact the primary provider. We can choose our trunk sequence from the list of available trunks 

with priority. 

 

Click on the “Create” button to update the configuration. 

3.2.14 Assign Rules to Extension Groups: 
Here you can map the required dial out rules to respective SIP extension groups. So that you 
can achieve the call restriction. 
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3.2.6 Call Queue: 
Refer Section: 4.4 

3.2.7 Voicemail Groups: 
Refer Section: 4.5 

3.2.8 Voice Files: 
Refer Section: 4.2 

3.2.9 IVR: 
Refer Section: 4.1 

3.2.10 Time of Day Routing: 
Refer Section: 3.7 

3.2.15 Create DID Range: 
Refer Section: 3.5 

3.2.16 Feature Settings: 
Refer Section: 4.6 

3.2.17 Customized Messages: 
Refer Section: 4.6 

3.3 SIP Extensions: 
Navigation: SETUP > SIP Extensions > Create Extension: This is where you setup your IP 
extensions 

Extensions Details 

1. Extension Number: This is usually the SIP user ID in the IP phone or ATA 
2. First Name: Enter the First name of the user 
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3. Last Name: Enter the last name of the user 
4. Email: Email ID of the respective user to receive the Voicemail alerts 
5. Password: To authenticate the SIP extension and Voicemail 
6.         Extension Settings: You can enable/ Disable Voicemail Settings such as Email alert on             
arrival of   new voicemail and MWI, Enable video calling (H264 codec support) 
7.         Group: Select the appropriate SIP group for that SIP extension. 
 
 

 

Show/Hide Advance Options: 

You can enable/disable Features like Voice mail, FAX, Call Pickup, callback, Call Park and so 
on.You can also configure various Codec’s and can also prioritize the active Codec’s using the 
up and down arrows. 
Click on “SAVE “upon the configuration.  
 

 

Important Note:  
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Make sure to click the SAVE ALL  button in the top navigation bar, after adding / editing / 
deleting any Extension. The SAVE ALL  tab turns Orange if some changes are made and not 
saved. 

 
Configuring our First SIP Client: 
 
With our extension created, we now need to configure a device to talk to MegaPBX. Any SIP 
device will do; but for a quick test, we will configure Counter path’s (http://counterpath.com) X-
Lite Soft Phone. The first time we run X-Lite, it will open up the SIP Proxy settings for us to enter 
the server information. Using our server and extension information, configure X-Lite as follows 
(leaving any unmentioned options at their defaults): 

  
                          Feature                                                               Configuration 

 Enabled                                                          Yes 

 Display Name     Any Name 

 Username      Extension Number 

 Password      Extension Secret  

 Authorization user name    Extension Number 

 Domain      IP Address of MegaPBX 

 

Once we have all the options set, close the windows and X-Lite will attempt to connect to our 
server. If everything is set properly, X-Lite will tell us that we are logged in and display our 
extension number. 
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3.3.1 Create Range Of Extensions: 
Navigation: SETUP > SIP Extensions > Create range of Extensions: This is where you can 
create range of user extensions all at a time. The details of the page are as follows: 

Extension Range: Select the number range from where the user extension has to start 
creating. (For Eg: 6000 to 6050) 

Group: Select the appropriate SIP Group for the extension range 

Voicemail Settings: You can enable/Disable the Email alerts on arrival of new voicemail & MWI 
Click on the “Create” followed by “Save All” button to update in configuration. 
 

 

Important Note: You can add Extension range of Max 50 users at a time and the maximum of 
250 SIP extensions  

3.3.2 Delete Range of Extensions: 
 
Navigation: SETUP > SIP Extensions > Delete range of Extensions: This is where you can 
Search and Delete range of user extensions. 
 
The details of the Configuration page are as follows: 
Extension Range: Select the range of user extension which is needed to be deleted (For Eg: 
6000 to 6100)  
It will search the range of Extension and you can delete or even edit the particular extensions. 
 
Click on the “Delete” followed by “Save all” button to update the configuration changes. 
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3.3.3 Create Extension Group 
You can enable/disable Features like Voice mail, FAX, Call Pickup, callback, Call Park and so 
on. 
You can also configure various Codec’s and can also prioritize the active Codec’s using the up 
and down arrows. 
By Default there is a Extension group called “Default sip”. You can limit or enable PBX features 
for extensions by creating Extensions group. 
  

 

Click on “Save “button, followed by “Save all” button to update the configuration changes. 

3.3.4 Manage Extension Group: 
Administrator can edit or delete the Extension group in this configuration page. 

Click on “Save “button if you have edited the Extension groups, followed by “Save All” button 
to update the configuration changes. 
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3.4 SIP Trunks 

3.4.1 Add SIP Provider: 
Navigation: SETUP > SIP Trunks> Add a SIP Provider: This is where you can configure VoIP 
Service provider Accounts 
The details of the Configuration page are as follows: 
 
Account Name: SIP service subscriber name which will be used for Caller ID display. 
User Name: User account information, provided by VoIP service provider (ITSP), usually has 
the form of digit similar to phone number or actually a phone number. 
Proxy Address: IP address or Domain name provided by VoIP service provider. By default port 
number will be 5060 
Out Bound Proxy Address: A proxy that receives requests from a client, even though it may 
not be the Server resolved by the Request-URI. Out bound proxy IP Address provided by the 
VoIP service provider. 
Authentication: Used for SIP trunk authentication.  If Authentication is required, check 
Authentication box and enter Authentication user name and Password provided by the VoIP 
service provider. 
Registration Mode: Enable if registration required from the VoIP Service provider 
Registrar Address: Domain name/ IP Address of registrar. If the registrar address is not 
provided by the Service provider use the proxy address itself 
Bridge PIN: This password is required to bridge the VoIP calls between two trunks. If not 
required, leave it blank. 
SIP Trunk Group: Select the appropriate SIP Trunk Group. 
Inbound Call Handling: This feature allows you to route the incoming calls to particular 
extension/ IVR/Queue/Voicemail Group. 
 

 

Click on “CREATE “button, followed by “Save All” button to update the configuration changes. 

3.4.2 Add a SIP Trunk group 
Navigation: SETUP > SIP Trunks > Add a SIP Trunk Group: This is where you can create a 
SIP Trunk Group. The details of the Configuration page as follows: 

Group Name: Enter a descriptive name in this field to identify the configured SIP trunk Group 
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DTMF Mode: You can enable/Disable the Email alerts on arrival of new voicemail & MWI 
Features:  You can enable/Disable NAT, FAX and DID Routing 
      NAT: It should be check if the device is behind a NAT router. Enable this option to              
avoid NAT Traversal issues. 
      Fax: If it is checked then T.38 supported, if unchecked only FAX pass through is   
supported. 
      DID Routing: This field is used to route incoming calls when a DID (Direct Inward 
Dialing #)   is used instead of the account ID. It is very helpful when there are several DIDs             
related to the same (static) trunk provided by your SIP Trunk Service Provider. 
Codec Configuration: This field allows you to enable a Codec's according to your preference. 
 

 

 
Click on the “CREATE” followed by “SAVE ALL” button to update in configuration. 
 

3.4.3 Manage SIP Trunk Group: 
Administrator can edit or delete the Extension group in this configuration page. 

Click on “Save “button if you have edited the Extension groups, followed by “Save All” button to 
update the configuration changes. 

 

 

3.5 DID Routing 
Inbound routing takes incoming calls and routes them to their destination. It is also known as 
DID or Direct Inward Dialing. Inbound routing is based on the phone number the calling party 
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dialed to determine the caller's destination. Every setup that will accept incoming calls will have 
at least one incoming route. In larger setups, individual users or departments may get their own 
DID numbers. 

3.5.1 Add a New DID: 
By clicking on the SETUP > DID Routing > Add a New DID link on the left-hand side MegaPBX 
menu, we reach this section: 

DID Number: This specifies the phone number the calling party dialed in order to reach you, 
which is provided by the VoIP Service Provider 

Route To: The final step in configuring the incoming route is setting the destination. The 
destination for any inbound call can be a IVR, extension, voicemail, Call Queue or any other 
currently available destination. 

 

Click on the “Create” followed by “Save all” button to update in configuration. 

3.5.2 Create DID range: 
By clicking on the SETUP > DID Routing > Create DID Range Extensions link on the left-
hand side MegaPBX menu, we reach this section: 

DID Range: Specify the range of the DID numbers provided by the Service Provider. 

Extensions: Specify the starting number of the SIP extension, which is to be mapped with the 
DID numbers and click on Map. 

Click on the “Create” followed by “Save all” button to update in configuration. 
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3.5.3 Delete DID Range:  
By clicking on the SETUP > DID Routing > Delete DID Range Extensions link on the left-
hand side MegaPBX menu, we reach this section: 

Here you can enter the range of DID and Click on “Delete” button. It will delete   DID route 
associated with respective DID’s. 

 

 

3.6 Dial Out Rules: 
 

One of the tricky concepts while configuring MegaPBX is learning how to create good outbound 
routing rules. A primary usage of outbound routing rules that has been common for many years 
is least-cost routing. With traditional PBX systems, we might have used least-cost routing to pick 
one provider for local calls, another for in-state calls, and yet another for out-of-state calls. In 
some cases, this is still a valid usage of outbound routing rules. With a modern PBX such as 
Asterisk, there are many reasons to set up different outbound rules: 

• Send 999/911/611 calls to an analog line to ensure that emergency calls go out through 
the analog lines. 

• Use a different provider for international calls for cost savings. We can use VoIP for our 
international calls and go through an ITSP for substantial cost savings. 

• Send toll-free calls through a specific provider. 

• Use different rules if users dial 9 first, for example to use 9 for an outside line. 

 

3.6.1 Add New Dial Out Rules: 
By clicking on the SETUP > Dial out Rules > Add New Dial Out Rules link on the left-hand 
side MegaPBX menu, we reach this section: 
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An outbound routing rule is made up of several components: 
Name: Provide proper rule name 

Description: Provide the proper description for the Dial out rule name 

 

Patterns: We should take care to create valid dial plans so as to ensure that our calls are 
handled via the appropriate trunks.Many people get confused about dial plan pattern 
construction; but it doesn't have to be that difficult. The following table lists the special dial plan 
pattern characters and their significance: 

 

 

 

 
  Special Dialplan Pattern Characters                             Significance 
   
     X               Matches any digit from 0-9 
               Z                                                                                    Matches any digit from 1-9 
               N                                                                                   Matches any digit from 2-9 

   [1237-9]                                                                          matches any digit or letter in the brackets (in this            
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                     Example 1,2,3,7,8,9 

           .                                                                    Wildcard; matches one or more characters 

           |                                                                   Separates dialing prefix from number 

For e.g. adding '01|X.' in the Dial Pattern and selected a “VoIP Provider1” in Trunk Sequence, 

will allow user to dial 014567807890 numbers, so that 01 will be stripped off from the dialed 

digits and only 4567807890 are dialed through VoIP Provider1. (Where as a VoIP Provider1 is 

an account which is registered to any Internet Telephony Service Provider) 

Second way is, choose provider or trunk based on actual number dialed. This type of rule will 

allow the user to choose suitable provider based on actual number. For e.g. adding ' 44X.' in 

Dial Pattern and selected VoIP Provider 2 in trunk sequence, PBX will allow number dialed from 

44 + (any digit from 0 to 9) like 449872837532 will route through VoIP Provider 2. If the ITSP / 

VoIP provider offer cheaper rates for the region where number starts from 44 users can make 

use of this rule. 

Enable Ceasing Of Trunk: This feature enables 2-stage dialing. For Example: If you have 
created dial out rule with pattern “0” and enable ceasing of trunk. While dialing out you need to 
press “0” and wait for the line dial tone and enter Calles number 

Trunk Sequence: The final phase of creating the dial plan is setting the trunk sequence. Not all 

dial plans have multiple trunks available for use, such as the remote extensions example. In 

other cases, such as long-distance dialing, our preferred carrier would be first, followed by a 

backup provider in case we max out the available channels, or if the system was unable to 

contact the primary provider. We can choose our trunk sequence from the list of available trunks 

with priority. 

Click on the “Create” followed by “Save all” button to update in configuration. 

 
 

3.7 Time of Day Routing: 

3.7.1 Add a New Time Based Routing Rule: 
 

By clicking on the SETUP > Time of Day Routing > Add a New Time Based Routing Rule 
link on the left-hand side MegaPBX menu, we reach this section: 
 
Rule Name: Provide the rule name. It should be unique compared to IVR and Voice file name. 
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Description: Provide the proper description for the Time based routing rule. 
 
Route To: Configuring the incoming route is setting the destination. The destination for any 
inbound call   can be a digital receptionist, extension, voicemail, Call Queue or any other 
currently available destination. 
 
Duration: This field let you enter the time range to play the IVR during the days it is  
                  Set to play. 
 
Day Selection: This field lets users configure the auto-attendant voice menu to be played on  
                           Specific days of the week. 
 
 

 

Click on the “Create” followed by “Save all” button to update in configuration. 
 
Important Note:  

Make sure that the current date and time are configured correctly under SETUP> Date/Time 
Configuration 

 
 

3.7.2 Add a New Time Route Group: 
By clicking on the SETUP > Time of Day Routing > Add a New Time Route Group on the left-
hand side MegaPBX menu, we reach this section: 
 
Time route Group: Specify the Time route group name 
Description: Provide the proper description for the same 
Add Time route rule: type the name of the “ Time of the Day Routing” rule and click “ADD” 
button. 
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Click on the “Create” followed by “Save all” button to update in configuration. 

3.7.3 Manage Time Route Groups: 
Administrator can edit or delete the Manage Time Route group in this configuration page.Click 
on “Save “button, followed by “Save all” button to update the configuration changes. 

 

 

 

3.8 Network Settings: 

 
The Networking Setting sub menu allows users to configure the LAN-side IP address and DHCP  
Server settings, as well as the WAN-side settings like IP address of the WAN port. 
 
By clicking on the SETUP > Network Settings link on the top navigation of the MegaPBX 
menu, we reach this section: 
 
WAN Configuration: Are the Internet settings of your MegaPBX. 
 

1. DHCP: when enabled and a DHCP server is available, the MegaPBX will auto 
configure itself. If DHCP is not available, select “Static”, and fill in the Network 
Configuration 

2. IP Address: the IP address corresponding to your WAN configuration* 
3. Net mask: the Net mask corresponding to your WAN configuration* 

                  4. Gateway: the IP address corresponding to your Gateway* 
                  5. DNS 1: the IP address corresponding to a DNS server* 
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                  6. DNS 2: the IP address corresponding to a DNS server* 
 
Important Note: DHCP mode isn't recommended WAN side. Or trouble may arise when SIP 
Extensions need to change registration server address caused by revised IP. 

LAN Configuration: 

Use this setting in the event that you want to use the MegaPBX as your network router. 

1. IP Address: It is a Base IP Address of a LAN Port, which functions as a gateway 

for its LAN. Default value is 192.168.113.1* 

2. Net mask: the Net mask corresponding to your LAN configuration* 

3. DHCP IP Start: The first IP in the lease range* 

4. DHCP IP End: The last IP Address in the lease range* 

5. DHCP Leases: allows users to specify the number of hours an IP address  
                                     is leased to a device before renewal. 

 
Important Note: WAN port IP and LAN port IP Address shouldn't be in the same net segment. 

 

NAT Configuration: 

NAT: NAT option is checked, when the MegaPBX is behind the Router/Firewall 

Stun Server IP: If the MegaPBX is behind a non-symmetric NAT router, it may be necessary to 
use STUN   to allow MegaPBX to reliably communicate via IP through the router. Enter a STUN 
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server IP address or domain name in the STUN Server field. For a list of public STUN servers, 
please Refer to: http://www.voip-info.org/wiki/view/STUN 

External IP: Enter the NAT Traversal IP address i.e. Public IP Address of your internet , to 
communicate with Public   Network when MegaPBX is behind the NAT. This IP address will 
substitute in all outgoing SIP messages instead of Local IP address. 

Click on “APPLY “button, followed by “SAVE ALL” button to update the configuration changes. 
Call Recording Configuration:  

Enabling the call recording: It will store the live voice streams in the server database. Please 
mention the server IP address in “server address” field 

Note: Make sure you enable recording for extension for which you want to record voice packets. 

3.9 Network Services: 
By clicking on the SETUP > Network Services link on the top navigation of the MegaPBX 
menu, we reach this section: 

SIP Port: The local listening UDP port for SIP messages. By default 5060 
RTP Port Range: MegaPBX will start listening for media transfer on ports 16001 to 17000. 
Make sure you configure this dynamic range of ports on your NAT Router. When the MegaPBX 
is behind a NAT and    the NAT is configured to do port forwarding with above mentioned port 
range for UDP ports. 
UDPTL Port Range: By default port range is 17000 to 18000 and it is used for T.38 FAX relay 
 

 

Click on “APPLY “button, followed by “SAVE ALL” button to update the configuration changes. 

3.10 Date/Time Configuration: 
By clicking on the SETUP > Date/Time Configuration   link on the top navigation of the 
MegaPBX menu, we reach this section: 

Time Zone: Select the correct time zone for the location where the MegaPBX is installed using 
the Time Zone   dropdown box. 
Manual Configuration: Input the proper date and time. 
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NTP: URI or IP address of the NTP (Network Time Protocol) server, which will be used by the 
phone to synchronize the date and time. For Eg: pool.ntp.org 
 

 



MegaPBX- Advance Settings 

 

 

4. Advanced Settings 
 

4.1 IVR 
What is an IVR? 

An IVR is a pre-recorded interactive operator defined by a sequence of actions that provides a 
customer with a better call experience. An IVR can be ‘chained’ with other IVR’s creating a 
multi-level IVR system. 

Let's take a look at a typical voice menu system for a small company: 

4.1.1 Create New IVR  
By clicking on the ADVANCED > IVR > Create a New IVR   link on the left side navigation of 
the MegaPBX menu, we reach this section: 

To create a new IVR, enter a Name and create the Sequence (the sequential order of events 
triggered by an IVR). When done, click the Create IVR button. 

There are different types of Sequences: 

Ring: Ring for selected number of seconds and Answer the call. 

Allow to Dial Local Extension: Plays any selected Voice File and waits for user to enter the 
local Extension/Directory. 

Play Announcement: Plays voice file with key press and performs key press action (defined 
when creating a Voice File) and Loop to how many times the IVR need to playback. 

Go to: Transfers the call to an Extension, Trunk, Queue, Voicemail group etc. 

Hang-up: To end the call. 

Example of an IVR: 

“Welcome to Allo.com! If you know your party’s 
extension, please dial it now. 

Press 1 for Customer Service 

Press 2 for Sales 

Press 0 for Operator Assistance. Thank you” 
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Lets create a IVR for the above mentioned example: 

Enter the IVR Name and Description then select the sequences to be followed,  

Select Sequence 1 and type as Ring  and click on Add button 

Select Sequence as  2 and type as Allow user to dial Local Extensions and click on Add button 

Select the voice file as Msg1 which was created in Create Voice file section. 

Select step as 3 and type as Play IVR and click on Add button 

Select the voice file as Msg2 which was created in Create Voice file section. And select the 
Loop as 3 so the IVR file plays for 3 times before taking further action. 

Select step as 4 and type as Go To & click on “ADD” button 

Select the option where the call has to go if the user does not press any keys. In the above 
example the call will be routed to the extension number 131 

Select step as 5 and type as Hang-up and click on “ADD” button 

This completes the IVR. Click on “Create” and then press SAVE ALL tab, to save this IVR. 

 

4.2 Voice Files 
Voice Files are the pre-recorded audio files. This files can be used for IVR Playback (With or 

without Key press), or which can be used for Music on Hold (the music that a user hears when 

his call on hold). These files can be recorded with any audio recording software, through the 

MegaPBX, or by hiring a Voice Talent. 

Example 1: Voice file without Key press 

“Welcome to Allo.com! If you know your party’s extension, please dial it now. 
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  Example 2: Voice file with Key press 

Press 1 for Customer Service 

Press 2 for Sales 

Press 0 for Reception” 

With the MegaPBX, you can either upload an existing voice file, or record your own. Accepted 
formats are: .wav format only.  

4.2.1 Record/upload Voice File: 
By clicking on the ADVANCED > Voice Files > Record / Upload a Voice File   link on the left 
side navigation of the MegaPBX menu, we reach this section: 

To upload a Voice File, enter the Name and Description, and click the Browse button to select 
the pre-recorded file from your computer. The file should be in WAV Format. After this, you may 
enter Key press Information if you like (see Key press section for more info). When done, press 
the “Create” button. 

To record a Voice File from MegaPBX, check the Recording Option, and select the extension 
you wish you use from the list, then press the  “ADD “button, it will ring the selected extension 
and allow you to record your voice through this extension for maximum of 1 minute. 

After answering the call a prompt will be played indicating you to start recording with beep 
sound once you have finished recording, press the # button.  It will play back the voice recording 
on your telephone and hung up the phone. 

Add Key press Information (see Key press section for more info). When you are done, 
click”Create” Button. The file will automatically be saved as an .Ulaw file, and be stored on the 
SD Card in your MegaPBX. 

Important Note: You can upload the voice file up to 5 MB (Max) and it should be .WAV format 
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Key Presses: Key press options are available to the caller when a Voice File is played back 
through an IVR. Depending what your voice File sounds like (see above example2) you can add 
any number of Key press Actions by first selecting a key number, and then the action (Example 
in the screen shot key press 5 go to Extension). Then Press the  +Add button to continue, then 
in the key press action select the extension number to ring repeat the above to continue adding 
more Key press Actions, as you desire. 

 

4.3 Schedule a Conference: 
The MegaPBX supports password protected conference bridges that allow up to 50 
simultaneous participants from PSTN trunks, SIP trunks or Internal SIP Extensions. 

By clicking on the ADVANCED > Schedule a Conference   link on the navigation of the 
MegaPBX menu, we reach this section: 

Conference Number: Enter the numeric number (For Eg: 9999) 

Date: Specify the Date to Schedule Conference 

Start Time: Specify the Time of Conference Schedule 

Duration:  Specify the duration of Conference should be active 

Admin PIN: Input a numeric password for Admin user 

Speaker PIN:  Input a numeric password for Speaker 

Listener PIN: Input a numeric password for Listener 

Add Participants:  Specify the privilege to be assigned to the participants 

Email ID:  After Specifying the privilege, enter the valid Email ID of the participant to send 
conference notification by email 

Add Dynamic Participants: If field is checked, Admin user can invite the participants 
dynamically through Administrator Web panel or user login web panel ( Refer page No: , for 
user login web GUI access) 

Outbound Dialing: Provides outbound dialing feature for the users who are in conference 

Maximum Participants: Specify the Maximum Number of participants to be allowed. 
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Click on “SCHEDULE “button, followed by “SAVE ALL” button to update the configuration 
changes. 

Important Note:  

1. MegaPBX supports up to 50 simultaneous participants with irrespective of the number of 
Conference bridges 

2. Make sure that the current date and time are configured correctly under SETUP> Date/Time 
Configuration for the proper functioning of Conference Schedules 

 

4.4 Queues/ Ring Groups 
The call queue is one of the most advanced features of Asterisk. Queues used to distributes 
incoming calls in the order of arrival to the first available extension in the queue. The system 
answers each call immediately and, if necessary, holds it in a queue until it can be directed to 
the next available extension. This feature is used to balance the workload among group of 
extensions. Queues will provide the following functions, Incoming calls being placed in the 
queue Extensions that answer the call in the queue. Option to choose ring type strategy, to 
handle the calls in the queue and distribute the calls in the queue. Music played while waiting in 
the queue. 

Call queues are extremely valuable in sales and support organizations where inbound call 
volume can sometimes exceed the number of available agents. This provides a level of 
additional call capacity to the company while assuring the caller that they will be taken care of in 
the order that they called in, rather than having to continually call back. 

When planning our queues, we should record: 
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• A unique name for the queue 

• A unique number to identify the queue 

• The announcement to be played to the caller periodically 

• Category of hold music to be played 

• Ring strategy 

• Static members of the queue 

 

4.4.1 Create a Call Queue 
By clicking on the ADVANCED > QUEUES > Create a New Call Queue   link on the left side 
navigation of the MegaPBX menu, we reach this section: 

Queue Name: Each queue can be assigned a name that is used for display purposes only. 

Strategy: we can use different ring settings to determine the call flow of the queue. The ring 
strategy       supports multiple settings including ring all, round robin, least recent, fewest calls, 
random, and round robin with memory 

a. Ring All: Rings all available extensions 
b. Round Robin: Takes turns ringing each available extension 
c. Least Recent: Rings the extension which was least recently called by this queue 
d. Fewest Calls: Rings the extension with fewest complete calls from this queue  
e. Random: Rings a random extension 
f. Round Robin Memory: Performs a Round Robin remembering where we left off with the        

last ring pass 
 

Description:  Specify the proper description for the call queue 

Queue Length: The maximum number of callers waiting in queue for an available extension 

Queue Members: This setting allows you to select the extension to be part of Call Queue 

Frequency: This setting adjusts the frequency to announce the caller's queue position. 

Play with Sound: This setting allows in selecting the Voice file, when caller is in Queue 

Queue Time Out: Select the required seconds so that the queue will get terminated after the 
given seconds 

Member Time Out: This sets the amount of time an agent's extension can ring before the 
system considers it a timeout. 
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Wrap up Time: After an agent finishes a call, this setting adjusts the amount of time to wait 
before sending another call to this agent. This will need to be adjusted to match the workflow of 
the agents. 

 

Click on “CREATE “button, followed by “SAVE ALL” button to update the configuration 
changes. 

 

4.5 Voicemail Groups 
A Voicemail Group is a pre-programmed group of voicemail recipients. All the members of this 
group will receive the same voicemail message. 

By clicking on the ADVANCED >Voice Mail Groups > Create a New Voice Mail Group   link 
on the left side navigation of the MegaPBX menu, we reach this section: 

Group Name: Specify the name for the voicemail Group 

Description: Provide the description for the voicemail Group 

Add Member: You add the SIP Extension, who wants to be part of the voicemail group 

Click on “CREATE “button, followed by “SAVE ALL” button to update the configuration 
changes. 
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Accessing, Retrieving & Managing Voice Mail 
 

The MegaPBX allows users to manage voicemail through voice messages in their phones. This 

section will summarizes how to access, retrieve and manage voicemail and other settings. 

The default feature code for accessing Voicemail is 800. After dialing this code, you will enter a 

basic voice menu with the option to listen or forward messages and configure voicemail options. 

When prompted, provide the appropriate Voice Mail number and the password, which is same 

as it was configured in the Create > Extensions i.e. Extension # & Password. 

  While you listen to the recorded voice message you can use the following keys for navigation. 

Voice mailbox Main Menu: 

Press 1 for new Messages 

Press * for help 

Press # to exit 

 

Press 1 for New Messages: 

Press 5 to repeat the same voicemail 

Press 7 to delete current message 

Press 8 to Forward message to another mailbox 

Press 9 to save message in a folder 

 

Press 8 to Forward message to another mailbox: 

Press 1 to prepend to existed voicemail 

Press 2 to send without prepending 

 

4.6 Feature Settings: 
By clicking on the ADVANCED >Features Settings   link on the top navigation of the MegaPBX 
menu, we reach this section: 

Extension Settings: 
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1. Pickup: This feature code is to pick up the ringing extension from another extension if 
the party is not available in the desk. By Default Feature code is “*9”. 

For Eg if *9 is your call pick up code , by dialing *91002 from any other extension  you 
can attend  1002 phone extension is ringing 

2. Conference: Using this feature code you can enter into the conference room. By Default 
the Feature code is “*900”, i.e. Dial *900 from your phone. It will prompt you for the 
Conference Number and the PIN and it will let you enter into the conference room. 

3. Dynamic Conference: Using this feature code you can enter into the conference room. 
By Default the Feature code is “*901”, i.e. Dial *901 from your phone. It will prompt you 
for the Conference Number and the PIN and it will let you enter into the conference 
room. To add users into the conference *0 then followed by extensions. 

4. Voicemail: This is to assign the code for accessing the voice mail. This will allows end-
users to change their personal settings for voice mail handling. By dialing to this number, 
any users who are registered to MegaPBX can access the Voice Mail. i.e dial *800 from 
your phone and follow the instructions. 

5. Directory: Using this Feature code you can dial the other extension with first and last 
name configured in the PBX 

 

Call Parking Settings: 

1. Parking: Using this feature code you can park the number of calls. By Default the 
Feature code is “*700”. i.e. park a caller by dialing *700 by using transfer button on your 
phone and will announce parked number 701. 

2. Parked: Using this feature code you can retrieve the parked calls. By Default the Feature 
code is “701”. To retrieve the call, the user can go to any phone in the group and dial the 
parked number “701”. Then call will be retrieved and connects to the retrieved user. 
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3. Number of Slots:  number of calls you can be parked. 

4. Time Out:  Time to lift the call which has parked. If this time is over then call will ring 
back the same extension from where it has parked. 

5. FAX Settings: Specify the format to receive the FAX by email either PDF or TIFF format 

Voicemail Options: Enable/Disable Voicemail, email alerts for new voicemail, MWI 

Call Back Settings: 

1. Callback prefix: Prefix number to initiate the callback. 

Default Value = *4 . 

Eg: If you want to make call back between your phone  and remote party 2002, dial 
*42002 from your phone then it  will hangup automatically. The remote party side he will 
get the call and once he answer the call, you will get the call back. Suppose If remote 
party didnt answer the call , it will retry the call with retry count. 

2. Retry Options: 

Attempts: Number of Retry attempts if remote participant didn’t answer the call. 

Timeout: Seconds to wait for an answer. Default is 10sec.  

Interval: Seconds between retries. Default is 30sec. 

Customized Messages: Allows you to customize the FAX/Voicemail message/ Conference 
Notifications, which will be sent to the specified Email-ID’s. 

 

Customized Voice Prompts: Allows you to select voice prompt languages. Currently 
MegaPBX supports English, Spanish, Turkish and French languages. 
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4.7 Directory Services 
The directory can be configured to find users by last name or by first name, the caller can hear 
the recipient's number before being put straight through. 

4.7.1 Add a Directory Entries: 
By clicking on the ADVANCED > Directory Services > Add a Directory Entry   link on the left 
side navigation of the MegaPBX menu, we reach this section: 

Extensions: Specify the Extension Number 

First Name: Enter the First Name 

Last Name: Enter the Last Name 

  

Click on “CREATE “button, followed by “SAVE ALL” button to update the configuration 
changes. 

4.7.2 Import Directory Entries: 
You can import the directory entries by browsing the corresponding file. File has to be in .CSV 
format.  

 

4.7.3 Export Directory Entries: 
You can export the Directory Entries by specifying the filename. The File will be exported to the 
local computer  in .CSV format  
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4.8 CDR Settings: 
The call records can be exported to Radius server or FTP server. 

Radius Server Configuration: This will allow you to configure the radius server information 
where all the records will be saved. 

Enable Radius Server:  EnableRadius field to for Enable RADIUS access control 
EnableRadius = Enabled, Radius Accounting of Call Detail Record should be enable and allows 
administrator  to configure the configuration parameters 

Server IP Address:  IP address of the Radius Sever 

Server port: Port number of the Accounting Radius server 

Password:  Shared password between radius Client and server 

Radius VSA Attrib:  To specify the Radius Vendor specfic attribute ID. 

Applicable values: CISCO, DIGIUM 
Default value:  CISCO 
 

Radius Retry Count: 

Value: Integer value ( 1 to 10) 
Default value: 2 sec 
 

Radius Retransmission Interval: 

Value Integer Value( 1to 10) 
Default: 3 
Radius Retransmission and radius retransmission interval is used  if there is no response from 
the Radius server 
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FTP Configuration: This will allow you to configure the FTP server information and CDR upload 
scheduling  

Enable CDR FTP Upload: Upon Enabling, allows administrator to configure the Remote FTP 
server parameters 

Server IP Address: IP address of the FTP server 

Server Port: Ftp Server Port (Default 21) 

User name: Username of Ftp Login  

Password: password of Ftp Login 

FTP Upload Schedule: This will allow you to configure the CDR upload scheduling by setting 
the Frequency of schedule, Day and Time. 

Frequency: This field to schedule the FTP file upload. We can schedule daily, weekly and 
monthly. 

Day: We can Specify the day (if the frequency=weekly) or date (if the frequency=monthly) for 
the upload. 

Time: Field to set the time for uploading FTP records. 
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5. Tools 

5.1 System Diagnostics 
 



  MegaPBX- Feature Handling 
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Ping Test: It is used to check the packet loss and latency time from your SIP end client like IP 
Phone/ FXS gateways to check the quality of your network connections. Enter the ip address of 
the IP Phone in your LAN and enter  “ PING” Button, it will displays  similar to like this: 

 

Trace route Test: It is used to determine the route taken by packets across an IP network. 

 

Format SD Card: This will allow you to completely erase all the contents in the SD card. 

Important Note: If you are formatting the SD card details, kindly take the back of the MegaPBX 
configuration. Kindly Refer Page No: 



  MegaPBX- Feature Handling 
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5.2 Backup/Recovery 
Navigation: TOOLS > Backup/Recovery: Here you can back up or Restore the MegaPBX 
Configurations. 

1. Backup Configuration: Allows you to create a backup of the existing Configuration and   
Voice files of the MegaPBX 

2. Restore Configuration: Allow you to upload a backup file to the MegaPBX, which is 
restored instantly 

 

5.3 Upgrade Firmware: 
The Firmware Upgrade page allows you to update the MegaPBX with the latest release 
available, which can contain key updates, added functionalities and bug fixes. When a new 
release is available, download it and save to your local PC. Then, browse for the file, and click 
the Upload button. Now your MegaPBX will display a Progress Screen and will prompt you 
when your MegaPBX is about to reboot. Let your MegaPBX reboot, and wait for the green 
LED’s to come back on. 

 

Important Note: During firmware upgrade there should not be any power or network 
disturbances, which may leads to MegaPBX board faulty. 

5.4 Admin Account Options: 
Navigation: TOOLS > Admin Account Options: Here you can change the administrator 
password and Configure Admin Email Settings    
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Change Password: This allows you to change the admin login Password. 

New Password: Enter the new password. It’s strongly recommended to assign alphanumeric 
password. 

PBX Admin Email Address: This allows you to configure the email account information for the 
admin. 

Mail Server: Enter the appropriate Email server. For Ex: mail.allo.com 
Port: Enter the SMPTP port number. By default: 25 
Email ID: Enter the Email address For Eg: perter@allo.com 
Username & Password: username and password of the respective Email Address 
TLS support: Enable if SMTP server expecting TLS authentication. 
 
 
 
 
 
 
 
 
 
 
 
 

6. Status 

6.1 Call Reports: 
Navigation: STATUS > CALL REPORTS this is where you can generate Call Reports 

To create a new Report, select the Extension Range or Date range, and click the “Generate” 
Report button. A list with call details will display in the Call Reports section. 
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You can either export to your local PC or Print the Call reports. 

 

 

6.2 SIP Trunk Status: 
Navigation: STATUS > SIP TRUNK STATUS this is where you find the status of SIP Trunk 
Status 

 

 

 
 

6.3 SIP Station Status: 
Navigation: STATUS > SIP STATION STATUS this is where you can find the SIP Station status 
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6.4 Current Calls/ Conferences: 
Navigation: STATUS > Current Calls/Conferences:  This is where you can find the active calls 
and current conference status 

 

 

6.5 Network Status: 
Navigation: STATUS > Network Status:  This is where you can find the LAN and WAN ip address and 
MAC Addresses. 

 

6.6 System Load: 
The System Info tool displays a lot of useful information and statistics on our server, such as IP 
address information, Internal& External Memory usage and system uptime. 
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6.7 System Events Log 
You can view the System event log such as SIP and RTP messages, which is useful for 
debugging. 

 

7.  Save All 
 

Navigation: SAVE ALL 

This is the button which you must press after adding / editing / deleting such things as 
Extensions, Voice Files, IVRs and modifying settings such as General Settings, VoIP Accounts, 
Network Settings, DID Routing, Firmware Upgrades, and other System Settings. 

 

 

 

 

8. Personal Web Login 
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To log into the personal web portal for an extension. Log into the MegaPBX  Web GUI using  
The extension number as Login ID and SIP Authentication password.  
 

 

After logging in, the following page will display 

 
 
User can change the user settings , access and manage Voicemails , Call Logs, Call Back and 
Conference Bridge. 

 
 

8.1 Settings: 
Do Not Disturb: The Do-Not-Disturb (DND) feature is great for phones that do not have a DND 
function on   the phone itself. This will simply reroute all inbound calls directly to our voicemail. 
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Enable call forwarding: If you want to allow Follow me feature for your user extension, check 
the “Enable Call forwarding” 

Forward to phone: Enter the Phone number where the call need to forwarded. Phone numbers 
may be internal SIP Extensions/ Mobile numbers.  
For e.g.: If  you  want add  9912254123 as Follow me number  and  if your Outgoing rule has  
Dial out Prefix as “8”, then you need  add “ 89912254123” as Forward to Phone. 
 
End Point Forward: In your desk IP Phone if you configured the call forwarding option, kindly 
check “End point forward”. So that End point Call forward takes the first preference. 

Forward on busy: If this option is checked, enables the call forward on Busy. If our Desk IP 
phone is busy with other call, then it could forward the call to a alternative numbers such as cell 
phone numbers or residence numbers configured in the “Forward to phone number” option. 
 

 

 
Change Web Access Password: In this section you can modify the Web access Password for 
the personal web portal for an extension. 
By default, the web access password will be SIP authentication password.   
 
Voicemail Settings: Here you can enable/Disable email alerts on arrival of new voicemail, 
Voicemail attachment via Email and MWI. 
 
Change Voicemail PIN: Here you can change the Voicemail PIN to New one. 
By default, the Voicemail PIN will be SIP authentication password.   
 
Change Email: Here you can change email ID to receive Voicemail Alerts and FAX. 

Click on “APPLY” after modifying the user settings. 

8.2 Voice Mail 
Here you can view and manage the New and Old Voicemails status which includes Time Stamp 
from user Extension. Also you can play the Voicemail from the user login web portal. 
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8.3 Call Logs 
Here you can view the detailed call logs of your user extension including the time of call, Call 
duration, and call status. 

 

8.4 Call Back 
If a person is not on desk and you want to talk to him immediately as he arrives at desk, then 
you can make use of this feature. You just call his extension number. Open the user portal GUI 
of your extension (Below is the user 2001 GUI page).  Call back Source number will be 2001 
and destination number will be the one from where you are expecting call back. Make sure you 
have are assigned with call back feature. The Call back feature will keep ringing destination 
extension number for every timer interval provided by the PBX. 
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8.5 Conference 
By clicking on the Conference   link on the Top navigation of the MegaPBX menu, we reach 
this section: 

Login Details:  

Conference ID: Enter the conference room ID 

Admin PIN: Enter the Admin PIN 

 

Important Note:  

1. Note that you should be able to login user conference in user webportal, provided you are 
currently participating the scheduled conference. Otherwise it will throw the below message 
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Once you log in to the User conference you manage that conference from WebGUI.You can 
even invite the participants, mute or kick out the participants from the conference room. 
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9. Managing & Handling MegaPBX Features 
 

9.1 Call Forwarding 
Call forwarding / Diverting is a telephony feature. If your phone is unreachable / out of service 
area or you do not wish to receive calls, the incoming calls can be diverted to other phone 
numbers. The Call Forward feature enables incoming calls to be redirected to any other 
telephone in the country. Outgoing calls can still be made even after you have activated Call 
Forward. Only incoming calls are redirected to another number. (Please refer Section 2.1 to 
activate and operation of this feature). 

9.2 Call Parking 
User can hold a call and retrieve it from another station within the group. To park a call, press 
transfer button followed by Call Parking feature code i.e. *700.The call is parked and the caller 
is held. And it will announce the parked extension (i.e. 701).  

To retrieve the call, the user can go to any phone in the group and dial the parked extension 
(i.e. 701). Then call will be retrieved and connects to the retrieved user. 

Use the following steps to park and retrieve the call: 

• While you are on a call, press the transfer button on your phone 

• Dial call parking feature code *700 

• PBX announces the parked extension (e.g. 701, 702 etc.) 

• Hang-up the phone 

• To retrieve the parked call, dial the previously announced parked number (701,702 etc.) 

9.3 Call Hold and Retrieve 
Enables users to automatically hold and retrieve incoming calls without requiring the use of 
feature access codes. This feature is especially useful for attendants managing a large volume 
of incoming calls. 

Any user can put a call on hold by pressing the Flash key. The extension on hold will start 
getting Music on hold. The same call can be retrieved back by pressing the flash key again. 
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9.4 BLF (Busy Lamp Field) Support 
MegaPBX supports BLF, which sends information about other extensions to a phone connected 
to the same PBX to inform the status. 

By default BLF Support is enabled. This feature is used by a receptionist or secretary for routing 
incoming calls. 

9.5 Hard Reset 
A reset button is provided in the back panel of MegaPBX. This will hard reset the MegaPBX. 
Press and hold the red button for 5-6 seconds, so that the MegaPBX will reset to factory 
settings.  

9.6 Memory Card Handling 
When handling a memory card, do so without touching the contacts on its edge. Make sure the 
card faces the correct direction if you are inserting it into MegaPBX memory card slot. Never 
force it into the slot. If it fails to insert into the slot fairly effortlessly, make sure it’s facing the 
right direction. Power-off MegaPBX before inserting or removing memory card. 
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10. IP Phones configuration required for MegaPBX 
Interoperability 
 
10.1 X-Lite Configurations 
 

Right Click on X-Lite -> SIP Account Settings -> Select Property of SIP Account 

=> Presence -> Refresh Interval -> 60 sec 

=> Advanced ->   Reregister every -> 60 sec 

If you have difficulty establishing a connection with the MegaPBX, give STUN Server 

=> Topology ->   STUN Server -> Use Specified Server -> “STUN Server IP Address” 

  

10.2 SNOM IP Phone Configuration 
 

Identity X -> SIP -> Proposed Expiry: -> 60 

Identity X -> SIP -> Subscription Expiry (s): -> 60 

Advanced Settings -> SIP/RTP -> SIP Session Timer(s): -> 60 

Advanced Settings -> QoS/Security -> Filter Packets from Registrar: -> Off 

 Linksys PAP2 ATA 

Admin Login -> Advanced View -> Line1 

NAT Mapping Enable: Yes 

NAT Keep Alive Enable: Yes 

Register Expires: 60 sec 
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11. Appendix A: Glossary of Terms 
 

ATA 

Analog Telephone Adapter: Used to connect a standard telephone to a high-speed modem to 
facilitate VoIP and/or fax calls over the Internet. 

DHCP 

Short for Dynamic Host Configuration Protocol, a protocol for assigning dynamic IP addresses 
to devices on a network. With dynamic addressing, a device can have a different IP address 
every time it connects to the network. DHCP also supports a mix of static and dynamic IP 
addresses. 

DID 

Direct Inward Dial. A specially configured phone line from the telephone company that allows for 
dialing inside a company directly without having to go through an attendant. A DID line cannot 
be used for out dial operation since there is no dial tone offered. However, it can be configured 
so an outside caller can reach an inside extension with a 7-digit number through the phone 
company's central office. 

DNS 

The Domain Name System is the system that translates Internet domain names into IP 
numbers. A "DNS Server" is a server that performs this kind of translation. 

GATEWAY 

A network point that acts as an entrance to another network. 

IP ADDRESS 

Every machine that is on a network (a local network, or the network of the Internet) has a unique 
IP number [four sets of numbers divided by period with up to three numbers in each set. (i.e. 
192.168.0.100)] - If a machine does not have an IP address it cannot be on a network. 

IVR 

Interactive Voice Response: A system to automatically manage incoming calls, IVR can link 
phone callers (voice and/or touchtone) with a computer database. It can accept a question, 
access the company's database and provide a caller with the information they are seeking. It 
can also take information from the caller, convert it to data and input that data to the database. 

LAN 
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Local Area Network: A LAN is a group of computers and associated devices that share a 
common communications line or wireless link and typically share the resources of a single 
processor or server within a small geographic area (for example, within an office building). 

NETMASK 

Used by the TCP/IP protocol to decide how the network is broken up into sub-networks (ex: 
255.255.255.0). 

PBX 

Private Branch Exchange: An in-house telephone switching system that interconnects telephone 
extensions to each other, as well as to the outside telephone network. 

PROXY 

A server that receives requests intended for another server and that acts on the behalf of the 
client behalf (as the client proxy) to obtain the requested service. A proxy server is often used 
when the client and the server are incompatible for direct connection. For example, the client is 
unable to meet the security authentication requirements of the server but should be permitted 
some 

SIP 

Session Initiation Protocol: An application-layer control protocol, a Signaling protocol for Internet 
Telephony. SIP can establish sessions for features such as audio/videoconferencing, interactive 
gaming, and call forwarding to be deployed over IP networks thus enabling service providers to 
integrate basic IP telephony services with Web, e-mail, and chat services. In addition to user 
authentication, redirect and registration services, SIP Server supports traditional telephony 
features such as personal mobility, time-of-day routing and call forwarding based on the 
geographical location of the person being called. 

PSTN 

Public Switched Telephone Network: This is defined as the regular telephone network services. 

VoIP 

Voice over Internet Protocol. The technology used to transmit voice conversations over a data 
network using the Internet Protocol. Such data network may be the Internet or a corporate 
Intranet. 

WAN 

Wide Area Network. A computer network that spans a relatively large geographical area. 
Typically, a WAN consists of two or more local-area networks (LANs). 


